Symptoms:
- I can't download the Unity Editor through the Hub.
- I'm getting the error 'Install failed: Validation Failed' while downloading the Editor.
- I see the error, 'Download failed: Validation Failed'.
- The Editor download doesn't finish.
- I'm stuck downloading the Unity Editor.
Cause:
The error 'Install failed: Validation Failed' is a generic message directing you to the logs for more detailed information. There are several potential causes for encountering errors while downloading the Unity Editor:
- System requirements: The machine may not meet the minimum system requirements for the Unity Editor and Hub.
- Hardware limitations: Installing the Unity Editor on external hard drives or other non-local storage may cause errors.
- Permissions: Insufficient permissions for the Unity Hub to install the Editor.
- Network issues: Connectivity problems, such as intermittent WiFi connection or data limits can corrupt the download.
- Antivirus and proxy software: Security & proxy software can block the download or installation process and corrupt the download.
- Machine-specific settings: Incorrect or empty PATH environment variables or non-Latin characters included in the file path can prevent the download and installation from completing.
Resolution:
The solution varies depending on the cause. To resolve errors encountered while downloading Unity, review each of the steps below:
Note: Since most download errors are related to specific machine or network configurations, we can only provide general recommendations. |
-
System requirements: Ensure that your machine meets the minimum system requirements for the Unity Editor and Hub. You can find out all of the system requirements in the Unity manual.
-
Hardware limitations: If your installation keeps failing, try setting your installation location to a local drive rather than an external one. Launch the Unity Hub > Preferences > Installs > Installs location.
-
Permissions: If you mistakenly didn't allow the Hub to make changes to your machine, the installation won't work. Run the Unity Hub with administrative privileges by right-clicking the shortcut or executable and selecting Run as Administrator.
-
Network issues:
- Connect directly via Ethernet: If you have a weak WiFi signal, it can help to use a wired Ethernet connection instead.
- Remove network data limits: If you have enabled data limits on Windows, navigate to Settings > Network & Internet > Ethernet and remove any data limits.
- Switch off VPN: Ensure that any proxy services are turned off and check that your internet connection is stable and strong.
- Check firewall settings: Allow ports 80 and 443 in your firewall settings to ensure the Unity Hub can connect to the server.
-
Speed test: Test your internet speed using tools like Speed Test and address any weak or intermittent connection issues with your ISP or Network Administrator.
-
Antivirus and security software: Temporarily turn off all security features of your antivirus software or firewall. Alternatively, try adding the following domains to your antivirus or web proxy exception list:
- unity.com
- unity3d.com
- plasticscm.com
- google.com
- googleapis.com
- microsoft.com
- aka.ms
Note: You can find our public guide for Defining exceptions on your web proxy
Additional steps:
If the above fails, try downloading Unity directly from the Unity download archive instead of using the Unity Hub. Don't select additional modules, as you can add these later to avoid download conflicts.
Alternatively, you can download and install editors and modules using the command line arguments.
If all else fails, try performing a clean installation of Unity.
More information:
If you continue to have trouble downloading Unity, contact the Customer Experience team with your log files and we'll do our best to help.
Comments
0 comments
Article is closed for comments.