Issue:
- When a build is triggered in the Unity Build Automation (UBA) service, it is canceled immediately.
- I am not able to start new builds using UBA.
- No logs are produced when I trigger a new build.
Environment:
On the Unity Build Automation Service on the Unity Cloud Dashboard, when launching builds from either the configuration page or the build history, the builds are canceled immediately when they are triggered.
Cause:
The most common causes for this issue are:
- The organization is on a Free DevOps plan and needs to convert to pay-as-you-go as the build would exceed the free usage available.
- There is a build minute cap in place and starting the build could exceed the pre-set usage cap.
Resolution:
On the DevOps menu from the Unity Cloud Dashboard, if you see "Free Plan" instead of Pay-as-you-go like in the following screenshot, follow the instructions in this article to register for a pay-as-you-go plan.
If you are on a pay-as-you-go plan but are still noticing that builds are being canceled without producing any build logs, the issue could be that you have set a build minute cap and are exceeding that established cap.
If you have an active subscription, the next thing to check is that you do not have a build minute cap set (and that your build may exceed the cap). You can check this in the Build Automation > Settings menu on the Build Consumption tab. If the value of "Build minutes monthly cap" is set to Enabled, you may need to disable it or increase the cap to continue using the service (if you are on or near your threshold).
If you have validated the above information and there are no current reported issues with the service (visible on the Build Automation menu when there are any issues), please reach out to the Service Support team by opening a ticket from the Help and Support menu.