Problem:
You're attempting to use one of Unity Cloud Services via one of our Rest APIs but are getting an error message: a 400, a 401, a 403 or something in the 500 range
Cause:
There's no 1-size-fits-all solution for this topic
Here are the basics:
404 - Resource not found - This usually means you've a typo in your URL
401 - Unauthorized - This means that either you've not submitted a valid Authorization header, or the token you used is one that's expired.
403 - Forbidden - This means that you've successfully set a valid Authorization header, but the thing you're trying to access isn't allowed. This might mean you've put in the wrong project ID, or it might mean that the user doesn't have the correct permissions.
400 - Bad Request - This could mean a number of things, but generally means that something in the body of your request isn't formatted correctly. There's usually more detail in the response here.
Further troubleshooting:
In your response, there should be a request-id
field.
If you're unable to figure out what the issue is, then contacting the Gaming Services support team describing the issue and including that request ID can enable us to investigate with greater detail.
If you're not getting a request-id
then sending us the URL and the time that the request was made (UTC timezone) will ensure that we start with all the information we need to investigate why your request failed.