Symptoms:
- A large number of duplicate events appear in the Analytics Event Browser dashboard.
- Duplicated events typically occur when users have a poor internet connection.
Cause:
Duplication Analytics events occur when an Analytics event matches the event_timestamp and event_name of a recently received event from the same user_id. It is more likely to occur if the player has a poor Internet connection during the event upload process.
Analytics events are cached locally on the game client and only deleted when the client receives a 204 response from the Analytics server, indicating that the events have been received. This prevents events from getting lost if the player goes offline or has a poor Internet connection.
The Analytics event ingestion and validation process detects duplicate events and redirects them to the Invalid Events data store. Duplicate events will not be validated or make it into your Valid Event Data and Reporting.
Valid and Invalid events can be viewed in the Analytics > Event Browser QA tool to aid integration debugging.
Resolution:
There is nothing to worry about. Duplicate events are normal in your Event Browser > Invalid Event tool. They will not be included in your Valid event data or reporting.
For more information please refer to the Unity Analytics > Event Browser documentation.