Summary:
This article addresses a common misconception when looking at the Acquisition Channels breakdown in Unity Analytics.
Your question:
When you look at the number of unique users, it's lower than the total number of users per acquisition channel.
You're most likely to notice that the number of users with None as their Acquisition Source is close to the total number of new users on a given day.
Cause:
Attribution information isn't always available when the game first runs for a player, so we initially record it as "None" until information is provided.
It is possible for attribution providers to provide more than one source for a player; and that information can be useful for identifying the total effectiveness of different providers; so we keep all unique values provided for attribution sources.
Resolution:
This depends on what you're wanting to understand with your Analysis.
If you're wanting to to understand how each attribution provider is performing, then you can do with the breakdown views so long as you keep in mind that there will be some overlaps.
If you're wanting to understand which player came from where first, then you can use SQL Data Explorer to filter which acquisition channels display for a given player, using a window function.
For example, use the following query to get the most recent acquisition channel for each user:
WITH fact_user_sessions_day_two AS ( SELECT *, ROW_NUMBER() OVER (PARTITION BY user_id ORDER BY inserted_timestamp DESC) AS rn FROM fact_user_sessions_day WHERE player_start_date = '2025-11-03' AND event_date = '2025-11-03')SELECT ACQUISITION_CHANNEL, COUNT(DISTINCT user_id)FROM fact_user_sessions_day_twoWHERE player_start_date = '2025-11-03' AND event_date = '2025-11-03'AND rn = 1 GROUP BY 1 ORDER BY 2 DESC;
That's what we do for our default acquisition dashboard in the Unity Analytics section of the Unity Cloud site.
Analysts should apply the necessary filters based on their specific needs; this article serves to help explain a mystery, or protect against a pitfall.
For further assistance with SQL queries or custom reports, please contact Gaming Services support.