症状:
- Asset Store でアセットを購入したが、ダウンロードできない。
- Unity エディタで購入したアセットを開こうとするとエラーが発生する。
- 購入したアセットが一部しかダウンロードされず、完了しない。
- "Unity で開くボタン"で購入したアセットが開かない。
原因:
Asset Storeで購入したアセットを自動的にダウンロードしません。アセットを使用するには、サポート記事アセットをダウンロードする方法の手順に従って手動でダウンロードする必要があります。
パッケージのダウンロード の際に問題が発生する場合があります。この記事では最も一般的なシナリオとこれらの問題の解決方法についてのご案内となります。
- エラー: パッケージを購入していない可能性があるため、購入詳細を取得できません
- Unityで開くボタンが機能しない
- パッケージの更新エラーが発生しました
- パッケージのインポートに失敗しました。エラー:パッケージを解凍できませんでした
- アセットのダウンロードが途中で停止する
エラー: パッケージを購入していない可能性があるため、購入詳細を取得できません
このエラーは、ダウンロードボタンをクリックしたときにパッケージマネージャーに表示されることがあります。ただし、実際にはダウンロードが停止することはありません。パッケージマネージャー内で再度ダウンロードまたはインポートをクリックすると、ダウンロードまたはインポートが通常通り開始されます。
Unityで開くボタンが機能しない
Unityで開くボタンをクリックしてもアセットのダウンロードが即座に開始されない場合、いくつかの理由が考えられます。推奨される解決策については、「Unityで開くボタンが機能しない」という記事で説明しています。
パッケージの更新エラーが発生しました
このエラーは、Unityエディタがパッケージマネージャーおよびアセットストアに接続できない場合に発生します。プロジェクトを保存し、エディタとハブを完全に閉じ、アプリケーションがバックグラウンドプロセスとして実行されないようにしてください。その後、ハブを再起動し、プロジェクトを開きます。パッケージマネージャーは通常通り動作するはずです。
パッケージのインポートに失敗しました。エラー:パッケージを解凍できませんでした
パッケージのインポートに失敗しました。エラー:パッケージを解凍できませんでした。このエラーは、アセットをダウンロードするのに十分な空き容量がマシンにない場合に表示されることがあります。ハードドライブおよび一時フォルダに十分な空き容量があることを確認してください。
このエラーは、ダウンロードが破損している場合にも発生します。この場合、アセットフォルダをマシンから削除し、パッケージを再ダウンロードする必要があります。アセットファイルは、以下の場所にあります。
- Windows: C:\Users\[UserName]\AppData\Roaming\Unity\Asset Store-5.x\[PublisherName]
- Mac: /Users/[UserName]/Library/Unity/Asset Store-5.x/[PublisherName]
上記の方法で問題が解決しない場合もあります。このフォーラム投稿には、この問題の影響を受けながらも解決策を見つけた他のユーザーからの推奨事項が記載されていますので、ぜひご確認ください。
アセットのダウンロードが途中で停止する
アセットのダウンロードが開始されたものの、途中で停止する場合は、以下の一般的な接続の問題が発生している可能性があります。
- ファイアウォールまたはプロキシが設定されており、サーバーへの接続がブロックされている。その場合、以下ポートを許可するよう設定を変更してみてください:80および443。
- VPNまたはアンチウイルスソフトウェアが実行されている。アセットをダウンロードする間、これらのソフトウェアを一時的に無効にしてみてください。
- インターネット接続が不安定または断続的である可能性があります。Unity はインターネットの安定的な接続を必要とします。ネットワークが強力で安定していることを確認してください。不安定または断続的な接続の問題が発生している場合は、イーサネット経由でのダウンロードをお勧めします。また場合によっては、インターネットサービスプロバイダまたはネットワーク管理者に相談してください。
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Unity Package Manager に問題があります。詳しくは、Unity Package Managerのトラブルシューティングに関するドキュメントを参照してください。
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