Symptoms:
- I would like to know how to download an asset I have purchased.
- I have not been sent a download link for my asset purchase.
- How do I download an asset using version 2020.1 and above?
- How do I download an asset I have purchased within Unity?
Cause:
As Unity does not ship Asset Store purchases using download links or product keys, you may be unclear about how to download your purchase or free asset.
As of Editor version 2020.1, Unity removed the Asset Store window from within the editor and you may be new to downloading your purchases using the Package Manager.
Resolution:
The Unity Asset Store does not use download links. Assets can be downloaded via the Unity Editor only.
Editor versions 2020.1 and above:
- If you have already purchased your asset/ added a free asset to My Assets, launch a new or existing Project using the Unity Hub.
- Once your Project is open, click Package Manager.
- Click the drop-down to select which packages you want to be shown.
- Click My Assets.
- Click the name of the asset you want to download from the left side list.
- Click Download in the bottom right corner of the window.
Once your asset has been downloaded, you can import it into your Project, or find the .unitypackage at:
Windows - User>AppData>Roaming>Unity> Asset Store-5.x>'publishername'
Mac - User>Library>Unity>Asset Store-5.x>'publishername'
Alternatively, browse the Asset Store using your internet browser and find the package you want to download.
- Click Open in Unity.
- This will launch the Unity Hub.
- Create a new Project or launch an existing one.
- This will launch your Project and bring up the Package Manager.
- Click Download in the bottom right corner.
Editor versions 2019.4 and below:
You will need ensure that you are logged into the Unity account that the asset was purchased on.
Please see the steps below on how to download assets once successfully purchased:
- Open the Unity Editor and launch an existing Project (or create a new one).
- Click Window > Asset Store.
- Log into your Unity account to access the Asset Store, if required.
- Find the asset you want to download by using the search bar inside the Asset Store window at the top of the page. Alternatively, you can click your name in the top right hand menu and click My Assets. This will give you a list of your purchases.
- When downloading an asset you have purchased previously, find the asset from the list and click Download to the right side.
- Alternatively, when using the search function for new/ free assets, click the blue Download button on the store page.
Once you have downloaded your assets, they can be found in the following locations:
Windows - User>AppData>Roaming>Unity> Asset Store-5.x>'publishername'
Mac - User>Library>Unity>Asset Store-5.x>'publishername'
If you are not able to reveal the Download or Import buttons upon pressing the Buy button, this means that your purchase has not gone through.
More Information:
Comments
12 comments
Where is "window" asset store i dont see it anywhere
Hi there,
To view the 'Asset Store' window, there is a button at the top of your screen within the Editor called 'Window'. If you click this, the 'Asset Store' button should appear in this drop-down list. Clicking this will generate the Asset Store window tab inside your editor.
If you still have any issues seeing this, please don't hesitate to contact us so we can investigate this more for you.
Why can you not just show us a list of assets we have purchased? An order list is not effective. Why should i guess which order number was the right one, instead of having a simple list of assets which i have already paid for?
Honestly this system is garbage, and a simple UI consideration that was misssed.
This is NOT WORKING here in version 2018.37 !
'My Orders' is blank.
I've tried the old version but not successfully....
mine keeps saying my account is offline while i'm connected to WiFi
Hi Kelvin,
Please ensure that you are not connected to the VPN while signing in to your account.
If the problem still persist, please submit a ticket to Support team along with the screenshot of the page for us to look into it.
This is stupid. I don't have the Unity Engine or a license for it, all I wanted is to download some photoshop files. I'm not going to pay for a Unity License just to get the stuff I already paid for. There has to be another way to get the pack downloaded.
My internet is good and I don't use VPN but I still can't Connect to the Asset store. Can somebody please help?
Terrible UX. Forcing me to download a 3.2GB Unity Studio so I can download my PSDs. Absolutely diabolical User Experience.
Such a massive barrier. No wonder why UNREAL is smashing it.
I solved the problem of importing an unity package or asset into Unity-3D through this website: To resolve the same please go through this website
https://atechdaily.com/posts/Import-Unity-package-or-Asset-into-Unity3D
Hello Aci and Phillipe.
Derek from Unity Customer Service here. Thanks for reaching out and for your valued feedback.
I can understand why you feel this is a difficult process.
Just to let you know, the Unity Asset store is intended for it's products to be used in the Unity editor. I can appreciate that this isn't everyones' preferred way but the Asset can only be downloaded from inside the Editor. I'm sorry about that.
If you would like to use the Assets outside of Unity, you can always just download the Unity Software, use it to access your purchases. Then you can just uninstall if you didn't want to have Unity installed on your machine.
I can appreciate that this isn't the intended method but if at any point you struggle with getting anything downloaded or want any advice on how to get Unity or Assets downloaded, you can always reach out to me or my team at support@unity3d.com.
We are happy to help. All the best.
Derek.
Hint for the location of the "Package Manager" Window:
The manager is under "Window" ->"Package Manager"!
This should be in the description! I was searching where do I find the Manager.
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