Symptoms:
- I tried to purchase an asset from the Unity Asset Store. Money was taken, but I cannot see the asset in my account.
- Money was taken, but the asset has not been added to my account.
- I received an error message: https://pay.unity.com/asv2/checkout?orderId=... when attempting to purchase from the Asset Store.
- When I try to purchase an asset, an error message appears: 'Unfortunately, we are unable to process your transaction at this time. Please double-check your billing details, try a new credit card, or contact your bank.'
- I see error 80.0408, but the transaction is still pending.
Cause:
The majority of assets are added to your account a few minutes after purchasing. Even if the asset has not been added to your My Assets section, you can go ahead and download it from your order section by clicking on the Open in Unity button:
Make sure you already have the Unity project open for the Open in Unity button to work.
However, if an error message appears in your transaction, it means the transaction did not actually go through.
Resolution:
The amount you see taken from your bank or financial institution in these cases is just a payment authorization attempt and not an actual charge from Unity.
Most financial institutions take up to two hours to release failed payment authorizations. If your order failed and you want to make sure the amount is released back into your account before proceeding with a second purchase, contact your financial institution.
Additionally, we recommend that you review the following support article before attempting a second purchase: Why is my Asset Store purchase attempt failing? to make sure your transaction does not fail again.
More information:
Why was I charged $1 after I added my credit card as the payment method?