Experiencing errors while purchasing assets from the Unity Asset Store can be due to various issues such as network blocks, mismatched billing details, unsupported payment methods, or bank/card issuer blocks. Common error codes include 500, 501, ESOCKETTIMEDOUT, and 80.133.194. Ensure your billing address matches your payment instrument, disable VPNs, use supported payment methods, and contact your bank if transactions are blocked. Failed transactions usually don't result in charges; funds are typically released within 72 hours.
Symptoms:
- I want to buy an asset, but I get an error message and cannot complete the purchase.
- I’m getting an error 80.133.194 when attempting to purchase an asset.
- I'm getting the error code 500 when trying to purchase from the Asset Store.
- I see an error 501 when attempting to purchase an asset.
- I see the error message 'ESOCKETTIMEDOUT' when trying to purchase from the Asset Store.
- Money was deducted from my account, but I can’t access the asset.
Cause:
Sometimes transactions in the Asset Store can fail during the purchasing process. These failures can be due to a variety of reasons.
Resolution:
| Important: If you received an error while attempting an order for an asset, it is highly unlikely that Unity has charged you. You may still see the charge to your credit card or Paypal account; however, this is usually just a payment authorization attempt. This means the amount is essentially in limbo and should be released by your financial institution in a period of 72 hours. |
There are many potential reasons for a payment failing in the Asset Store. Here are the most common causes and resolutions:
Your bank or card issuer is blocking the transaction:
By far, the most common cause of checkout errors is that your bank is blocking the transaction from completing on its side. When your bank or card issuer has flagged your transaction, they place what's known as a 'soft block' on your card. This is possible even if you have passed their security confirmation. In order to remove this block, you must contact your bank or card issuer directly and ask them to allow the transactions.
Personal network blocks:
IP mismatches create conflict with the transactions. Please disable any VPN or Proxy software you may be using. If this is because your internet service provider is altering your IP, we recommend using another network or a mobile hotspot as an alternative.
Billing details do not match the payment instrument:
Your billing address needs to match the address from your payment instrument exactly. Please check that the billing details listed on your Unity account and Organization match those of your credit card. This includes your address, postal/zip code, and country. You can update your billing information following the steps in our support article: ‘How do I add both the 'Bill To' and 'Ship To' details to my Unity Organization?’.
ESOCKETTIMEDOUT - Intermittent network issues:
The error code ESOCKETTIMEDOUT may occur after redirecting you back from your bank's security page. Most of these orders are completed within a few minutes. If you are unable to access the asset within 10 minutes, then the transaction has failed, and you need to try the purchase again.
An unsupported payment instrument:
The Asset Store accepts a wide range of payment methods. If your payment instrument is not listed in the store, your transaction will fail. Instead, you will need to use one of the accepted forms of payment:
Apart from this, the system would reject the payment if you use a debit card, virtual credit card, or gift card. Debit cards are only supported, providing they show VISA or MC (Mastercard) on the card itself.
Please make sure you are using a supported payment method.
Error 80.133.194: This transaction was flagged for additional review:
This error is related to an additional security measure in which accounts and transactions are routinely reviewed as part of Unity’s standard due diligence process. Contact Customer Experience for further assistance.