If you’re unable to leave a review for an Asset Store purchase, ensure you're signed into the correct Unity ID and have downloaded the asset. Reviews require a waiting period of at least 6 hours after purchase/download. Issues may also stem from system maintenance or account suspension due to prior violations. If problems persist, contact Unity’s Customer Experience team for assistance. Reviews are only allowed for purchased assets to ensure feedback is accurate and relevant.
Symptoms:
- Unable to post a review on a purchased asset.
- When attempting to post a review, I see an error message saying "Please download this asset to leave a review".
- Reviews cannot be posted from any device.
Cause:
You might not be able to submit reviews for purchased assets because you're signed into the incorrect Unity ID, there's ongoing system maintenance, or you're trying to review an asset too soon after purchasing/ downloading. You should wait at least 6 hours before posting a review of an asset you've downloaded or purchased.
You cannot post reviews for assets you have not purchased.
Note: If you're logged in with the correct Unity ID but still can't post a review, it might be because you were previously suspended for inappropriate actions. You'll need to wait until the ban is lifted or contact the Customer Experience team for help. |