Issue:
The Unity Analytics dashboard is not showing any data, despite following the Getting Started documentation.
Cause:
There are several reasons why your Analytics Dashboard might not be displaying data. The steps below will help you to identify and resolve the problem.
Resolution:
- Check your integration. Confirm that you have installed the latest Unity Analytics package, followed the Getting Started documentation, called the StartDataCollection() method in your script and that the script is attached to an active GameObject in your scene.
- Check the Analytics Debug panel. A debug panel was added to Analytics package 6.0.0. It can be accessed from the Services > Analytics > Debug Panel menu in the Unity Editor. It shows events being generated and uploaded. It will show error messages if there is a problem. You will see an - 'Upload Finished (204)' messages when events are successfully uploaded.
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Check the Unity Project. There is a chance that you may be sending data to a different project or environment than you expect, or that you might not have permission to access the project.
Open the Edit > Project Settings panel in the Unity Editor, and navigate to the Services panel to confirm that the Organization and Project settings are as expected and the Editor project is linked to your Unity dashboard.
Follow the Dashboard link in the Members panel to confirm that the project is correctly linked to the Unity dashboard.
Reach out to one of your Project or Organization owners if you can't see the correct Organization and Project in your Services panel, as this indicates that the user profile that you are logged into the Unity Editor with hasn't been granted the necessary project permissions.
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Wait for data to arrive. Data is uploaded from the game client at 1-minute intervals, processing and display can take another 5-10 minutes. Allow the game client to run for a couple of minutes then visit the Services > Analytics > Event Browser dashboard tool to confirm that data is being received.
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Network Traffic Analysis. Use a network traffic analysis tool like Charles Proxy to perform a more advanced analysis of the sent data. Filter for data being sent to collect.analytics.unity3d.com and check the projectId and environment that data is being sent to, the payload and the response code.
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Sample Project. Install and run the Unity Analytics Sample scene from the Analytics > Samples project. It can be installed from the Windows > Package Manager.
If you see data being sent from this project and can view it in your Analytics dashboard, it indicates an issue with your Analytics code.
Please review the sample project code and its attachment to a GameObject in the scene.
Next Steps:
If you are still unable to see data in your Analytics dashboard, please submit an Analytics Support Ticket and provide the following information.
- A link to your Unity Analytics project dashboard.
- The email address you are logged into the Unity Editor with
- The script file(s) used to initialize and send Analytics data
- The version of Unity Editor and version of Unity Analytics that is being used.
- A screenshot of the Inspector showing the script file attached to an active game object, while your project is playing in the Editor
- A Charles network proxy export file of an Editor play session with a duration of two minutes or more.
Further Reading:
- Unity Analytics Documentation
- Unity Analytics Community Discussions
- Introduction to Analytics for Games
- Using Charles Proxy with Unity