Symptoms:
- I get permission errors when trying to import the license archive file.
- I am getting the following error when importing the license file onto the License server:
"You do not have the necessary permissions to import licensing files.
Close the current Terminal session and open a new Terminal session or run the command: su - "$(whoami)"
- I can't use the floating license due to a permissions error when trying to import the license file.
Cause:
The main reason for this error is that your user account lacks permissions for the import operation.
For License Server v1.x, you might be attempting to run a license server command using an account other than the one used to set up the server.
For License Server v2.x, your user account must be part of the unity-licensing-server user group.
Resolution:
For Linux, adding 'root' to the 'unity-licensing-server' group solves the issue during the license import. However, there are other recommendations you should take into consideration that will be described below:
- For server v1.x, run the command using the same account that was used to run the setup. Ideally, this is a dedicated service account that was created explicitly to administer the server.
- For server 2.x, there are several scenarios that might cause this issue. Note that the following scenarios still apply, even if the commands are run with elevated privileges (Windows) or as root (Linux).
Scenario | Solution |
You ran the setup command and the import command from the same Terminal session. When you open a Terminal session, the operating system initializes that session with a snapshot of environment information, which includes group membership. Although the setup command adds your user account to the unity-licensing-server group, the existing Terminal session is unaware of this change. In short, the session is using cached information where you're not part of the unity-licensing-server group. |
Close the current Terminal session and open a new Terminal session. Or, run the following command: Then, rerun the import command. |
This isn't the first time the import command is being run, and another user imported the license file as part of the original setup. That user is part of the unity-licensing-server group. Now you're trying to import the license file again, but you're not part of the unity-licensing-server group. |
Have the original user run the import command. Or, get yourself added to the unity-licensing-server user group, then rerun the import command. |
This isn't the first time the import command is being run. Although you were the person who ran the setup command, you ran it using a different user name. |
Run the import command using the account you used to set up the server. Or, get your current user account added to the unity-licensing-server user group, then rerun the import command. |
More information:
Configure the licensing server