Symptoms:
- I am using Floating Licenses or Build Server Licenses.
- The client is running on macOS or Linux.
- I cannot launch the Unity Editor after it crashes or is terminated.
- I see an error with the code 0x8000000a in the Editor.log.
Cause:
The code 0x8000000a error occurs after the Editor crashes or is terminated. When the Editor closes ungracefully, a .sock file, which is used for communication between the Editor and licensing client, is retained. This prevents the Editor from establishing a connection on the specific IPC channel on subsequent launches.
Resolution:
If your project has been developed on Unity Editor 2020 or earlier, please update to:
- 2020.3.26f1 or higher.
- 2021.2.7f1 or higher.
- 2022.1.0b1 or higher.
If your project has been developed on Unity Editor 2019 or older, or if upgrading is not an option for you, you can remove the .sock file manually:
- Locate the .sock file on your computer by running the following command in the terminal.
Is /tmp/*.sock - This will output a list of socket files on your computer. You should see a file with a name similar to Unity-LicenseClient-[username].sock. This is the file that needs to be removed.
- Remove the file by running the following command in the terminal.
rm /tmp/Unity-LicenseClient*
More Information:
You can find the Licensing Client log in this directory:
- macOS: ~/Library/Logs/Unity/
- Linux: ~/.config/unity3d/Unity/
You can find the Editor log in this directory:
- macOS: ~/Library/Logs/Unity/
- Linux: /.config/unity3d/