Symptoms:
- I am running the Server and the Client on the same machine as a single user.
- I cannot open the Unity Editor or build from the command line, even though I can successfully obtain a license from the Server using the command line argument --acquire-floating.
- I am running version 1.8.0 or older of the Licensing Server.
- Clients on different machines can open the Unity Editor without any issues.
- My license .xml files have duplicate entitlement group ids.
Cause:
Running the server and client on the same machine as a single user is not supported in version 1.8.0 and older of the Licensing Server. In this case, the server license and the floating license will have the same EntitlementGroupID, and so the Unity Licensing Client ignores it to prevent the duplication of seats.
Resolution:
It is recommended that you set up a dedicated physical machine to run the License Server on separately to resolve this issue. However, the conflict can be avoided if the server is set up to run as a dedicated user.
This use case is supported in version 1.9.0 and newer of the Licensing Server, so updating will also resolve this issue.
More Information:
If you have already set up your License Server and wish to move to another machine, you will need to contact Customer Service and request your License Server be reset first.