Symptoms:
- Some of my Humble Bundle assets are missing.
- I redeemed my Humble Bundle voucher, but I only see some of my assets.
Cause:
Occasionally, assets entitlements are only added to an account a few hours after a Humble Bundle voucher had successfully been redeemed.
Once the entitlements have been added, the assets will appear in the user's My Assets section in the Asset Store.
Resolution:
If you do not see your assets in your My Assets section, it is necessary that you please double check if the assets entitlements have been already added to your Unity ID in the Asset Management section.
To review this, follow the steps below:
- Sign in at id.unity.com
- Click Organizations to the left of the screen.
- Click on the name of the Organization you used to redeem your voucher.
- Click Asset Management to the left of the screen.
- Check if the assets appear under this section.
If you see the asset in the Asset Management section but not in your My Assets section, it is worth trying to revoke and reassign your seats by following these steps:
- Sign in at unity.id.com
- Click Organizations to the left of the screen.
- Click on the organization you purchased your assets on.
- Click Asset Management.
- Click the Manage Seats icon to the right of the asset(s) not appearing in the Package Manager.
- Check the box next to your email address > click the red Revoke seat(s) button.
- Click the blue Assign seat(s) button to reinstate entitlement.
Please note: If your assets are not appearing under the Asset Management section of your Unity ID page within 48 hours after redeeming, please contact the Customer Experience Team indicating the following information:
- Name of the redeemed Humble Bundle.
- Name of the missing asset.
- Name of the Unity Organization where you redeemed the bundle.
More Information:
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