Symptoms:
- I have received an email saying: ‘Your license for <server name> will expire. Log in to your Unity ID to regenerate a new license to continue using <subscription name>.’
- My subscription plan is annual, prepaid yearly, and I have automatic renewal enabled.
- My production clients can connect to the license server, but the license can’t be acquired.
- The web request http://<SERVER-IP-ADDRESS>:<PORT>/v1/status returns Status: Unhealthy.
Cause:
The new license hasn’t been imported into the Floating License Server after the expiration date has been updated in the Unity ID Portal.
Resolution:
To import the renewed license into the Floating License Server, follow the steps below:
- Ensure the Expires field has been updated on the Unity ID Portal: Unity ID portal > Organizations > [Organization name] > License servers.
- Once the expiring date has been updated, click Download licenses.
- On the Server, import the new license using the following command:
Linux: ./Unity.Licensing.Server import <path-to-downloaded-archive>
Windows: .\Unity.Licensing.Server.exe import <path-to-downloaded-archive> - Restart the Service Unity.Licensing.Server.
- Test the Server using the following API call: http://<SERVER-IP-ADDRESS>:<PORT>/v1/admin/status
A positive output looks like this:"serverStatus": "Healthy",
"serverUpTime": "xx days x hours x minutes x seconds",
"serverUpTimeMs": xxxxxx,
"version": "x.x.x"
- On a Client, test its ability to acquire a valid license with the following CL commands:
Navigate to the Unity.licensing.Client installation path:
Windows: [Unity Editor Dir]\Data\Resources\Licensing\Client\Unity.Licensing.Client.exe
macOS: [Unity Editor Dir]/Contents/Frameworks/Unity.Licensing.Client.app/Contents/ /Unity.Licensing.Client
Linux: [Unity Editor Dir]/Data/Resources/Licensing/Client/Unity.Licensing.Client - Run the --acquire-floating command:
Windows: .\Unity.Licensing.Client.exe --acquire-floating
macOS: ./Unity.Licensing.Client --acquire-floating
Linux: ./Unity.Licensing.Client --acquire-floating
More Information:
If the server version is earlier than 1.10, expired delegation files can create a conflict. Please delete the old delegation files from the following directory:
- Windows: %LOCALAPPDATA%\Unity\licenses\delegations
- Linux: ~/.config/unity3d/Unity/licenses/delegations
If you do not see your license server on your Unity ID page, please email floatinglicense-support@unity3d.com for further assistance.