증상:
- Unity에서 열기 버튼이 작동하지 않습니다.
- Unity에서 열기 버튼을 클릭하였을 때 에셋이 열리지 않습니다.
- Unity에서 열기 버튼을 클릭하였을 때 에셋이 다운로드되지 않습니다.
원인:
Unity에서 열기 버튼을 눌러도 에셋 다운로드가 시작되지 않는 경우 컴퓨터에서 Unity 프로젝트와 패키지 매니저를 자동으로 실행할 수 없거나 네트워크에 연결 문제가 있는 것일 수 있습니다.
해결법:
Unity에서 열기 버튼이 프로젝트를 자동으로 실행하지 않는 경우, 먼저 Unity에서 프로젝트를 연 다음 에셋 스토어 홈페이지에서 Unity에서 열기 버튼을 다시 클릭하시기 바랍니다. 에셋을 다운로드하는 방법에 대한 절차는 에셋을 다운로드하는 방법 문서를 참조하세요.
프로젝트가 열려있는 상태에서도 여전히 에셋을 Unity에서 다운로드 하실 수 없는 경우 브라우저에서 팝업 창이 활성화되어 있는지 확인하여 주시기 바랍니다. 위 절차를 진행하신 후에도 관련 문제가 해결되지 않는다면 에셋의 다운로드를 방해하는 연결 오류가 있는 것일 수 있습니다. 이러한 경우, 아래의 내용을 확인하여 주시기 바랍니다.
- Unity 허브를 통해 Unity ID로 로그인했는지 확인합니다. 에셋을 구매하신 계정으로 로그인 되어있는지 확인하여 주시기 바랍니다.
- 설치되어있는 Unity 에디터 버전이 다운로드하려는 에셋과 호환되는지 확인합니다. 예를 들어, 2020.X에서 에셋이 지원되지 않는 경우 이전 버전의 에디터를 사용하여 에셋의 다운로드를 시도하여 주시기 바랍니다. 또한, Unity 2020.X 출시 이후 에셋 다운로드 프로세스가 변경되었기에 필요시 Unity 기술 자료 문서 '에셋을 다운로드하는 방법'을 확인하여 주시기 바랍니다.
추가적으로, 연결 문제를 해결하기 위해 네트워크 설정 문제를 해결해야 할 수도 있습니다. 네트워크 설정 문제를 해결하기 위하여 아래의 절차를 진행하여 주시기 바랍니다:
- 네트워크에서 프록시가 실행 중인 경우 설정으로 이동하여 포트 80 및 443을 허용하여 주시기 바랍니다.
- 바이러스 백신/방화벽 소프트웨어가 실행 중인 경우, 이를 일시적으로 비활성화하여 Unity를 열 수 있는지 확인하여 주시기 바랍니다. 일부 애플리케이션은 네트워크 연결이 원초적으로 차단되어 있기에, 이를 허용하기 위한 설정을 업데이트해야 하기 때문입니다.
- 인터넷 연결이 약하거나 간헐적으로 연결되는 것이 문제의 원인일 수 있습니다. 예를 들어 신호가 약한 Wi-Fi를 사용하는 경우, 보다 안정적인 연결을 위해 이더넷 케이블을 사용하여 주시기 바랍니다.
이 가이드를 따른 후에도 Unity에서 에셋을 열 수 없는 경우, 에셋 이름과 다운로드 시도 중 수행한 모든 단계의 화면 녹화본을 포함하여 Unity 고객 경험에 문의하여 주시기 바랍니다.
참고자료: