Users can leave a Unity organization unless they are the Primary Owner, who manages billing and subscriptions. To leave, go to https://cloud.unity.com/account/my-organizations, click the red Leave button next to the organization, and confirm. If the Leave button is greyed out, the user is the Primary Owner and must contact support to transfer ownership before leaving.
Cause
As a Unity user, you will be listed as either a User, Manager, or Owner of an organization. As an Owner of an organization, you are able to remove team members; however, as a User and Manager, you are still able to leave an organization of your own accord.
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Important: You cannot leave an organization if you are listed as the current Primary Owner. The Primary Owner is the owner who is responsible for all billing details, payment methods, Asset Store orders, and general subscription management. If you are the Primary Owner of an organization and need to change this role to someone else, you must contact support with the details of the new user taking their place. The new user must already hold a Unity account and be a member of the same organization. |
Resolution
To leave an organization that you no longer want to be a part of, follow the instructions below:
- Navigate to https://cloud.unity.com/account/my-organizations
- Select to red Leave button to the right of the organization you want to leave.
- Select Leave organization to confirm.
Note: If the Leave button is greyed out, it means you're the Primary owner and therefore not eligible to leave. See the article, 'How do I change the owner of my Unity organization? for more details.