Symptoms:
- I purchased an asset some time ago, but I can no longer download it.
- I want to purchase an asset, but it is no longer listed on the Asset Store.
Cause:
We have a ‘deprecate’ feature for our Asset Store publishers to use, which means that even if they wish to remove an asset from the store, users that have already purchased it will still have access.
An asset can be deprecated by the publisher due to a variety of reasons which can include, but are not limited to, the following examples:
- Refocusing development on new asset content.
- Deprecation due to being incompatible with the currently supported versions of Unity.
- A close of the publishers business.
- The publisher may no longer have the time or resources to provide future updates or bug fixes, due to other commitments.
- Deprecation due to the packages functionality being included in another upcoming package by the publisher.
Unfortunately, assets that were disabled before this feature came in are not accessible to users.
Assets uploaded to our store by publishers later deemed to be infringing on copyright or intellectual property are removed from our Asset Store. These are no longer available for any new or existing users to purchase or download.
Resolution:
If you downloaded the asset previously:
If you've previously downloaded the asset, the files may still be on your machine. Please search for the asset files in these locations:
- Windows: C:\Users\[UserName]\AppData\Roaming\Unity\Asset Store-5.x\[PublisherName]
- Mac: /Users/[UserName]/Library/Unity/Asset Store-5.x/[PublisherName]
Once you have found the .unitypackage, drag and drop the folder into the project to import it. Alternatively, right-click on the Editor project window, click Import Package > Custom package, and select the asset to import using the file explorer.

If you have not downloaded the asset previously and the asset is now deprecated:
If the publisher has deprecated the asset, only users who previously purchased it can continue to download it. As long as you are logged in with the purchasing account, the asset can be downloaded again via the 'My Assets' section of the Asset Store or via the Package Manager window, within the Editor.
If the download does not work, please get in touch with our Customer Experience Team with your original invoice number or order ID, and they will investigate and advise.
If you have not previously downloaded an asset that has since been disabled:
If the asset has been 'disabled,' this means it is no longer available to any users. Please contact our Customer Experience Team, and they will advise.
More Information: