This article explains what happens when assets are deprecated or removed from the Unity Asset Store. Deprecated assets can still be downloaded by users who purchased them, unless they were disabled before the deprecate feature was introduced or removed for copyright reasons. If you previously downloaded the asset, locate files on your device. If you cannot download a purchased asset, contact Customer Experience with your order details. Refunds are automatic if an asset is removed within six months of purchase.
Cause:
We have a ‘deprecate’ feature for our Asset Store publishers to use, which means that even if they wish to remove an asset from the store, users who have already purchased it will still have access.
An asset can be deprecated by the publisher due to a variety of reasons, which can include, but are not limited to, the following examples:
- Refocusing development on new asset content.
- Deprecation due to being incompatible with the currently supported versions of Unity.
- A close of the publisher's business.
- Due to other commitments, the publisher may no longer have the time or resources to provide future updates or bug fixes.
- Deprecation due to the package's functionality being included in another upcoming package by the publisher.
Unfortunately, assets that were disabled before this feature came in are not accessible to users.
Assets uploaded to our store by publishers later deemed to infringe on copyright or intellectual property are removed from our Asset Store. They are no longer available for new or existing users to purchase or download.
Resolution:
If you downloaded the asset previously:
If you've previously downloaded the asset, the files may still be on your machine. Please search for the asset files in these locations:
If you have not downloaded the asset previously and the asset is now deprecated:
If the publisher has deprecated the asset, only users who previously purchased it can continue to download it. As long as you are logged in with the purchasing account, you can download the asset again via the 'My Assets' section of the Asset Store or via the Package Manager window within the Editor.
If the download does not work, please contact our
Customer Experience Team with your original invoice number or order ID, and they will investigate and advise.
If you have not previously downloaded an asset that has since been disabled:
If the asset has been 'disabled,' this means it is no longer available to any users.
According to the
Asset Store refund policy, if an asset is removed from the store within 6 months of purchase, a refund will be processed automatically.
For further assistance, please contact our
Customer Experience Team.