Symptoms:
- My subscription has been suspended due to unpaid monthly payments.
- I would like to regain access to my subscription.
- I cannot use my subscription.
- When I log into my Unity ID, I see a warning message telling me to update my payment method.
Cause:
Subscriptions can be deactivated for a variety of reasons:
- Your payment instrument has expired.
- You are using a non-recurring payment method.
- Your payment was declined by the credit card issuer/ bank.
- There are not enough funds available on your credit card.
- There is a problem with a card attached to your PayPal wallet.
- Our Finance Team has reason to suspect fraudulent activity on your credit card.
If a monthly payment of a subscription is not paid on time, the license will be suspended. You will not be able to use the subscription license or purchase add-ons while there are outstanding payments on your account.
Resolution:
If your Unity subscription license has been suspended due to outstanding monthly payments, you must pay the total amount left outstanding on your subscription before you can use it again.
As subscriptions cannot be paused, all monthly payments that have been missed will be taken once your payment details are updated. This is only applicable to those still within a 12-month commitment period.
To update your subscription payment method, see the steps in the article, 'How do I change or update the payment method on my account?'.
Unity Pro and Unity Plus subscriptions that have a legacy 'flex' term will expire if payment is not made within 14 days of the due date. Subscriptions cannot be reactivated once expired.
After your subscription has expired, you will need to purchase a new one on the Unity Store page. Please note, that this will enter you into a new 12-month commitment period.
More Information:
How do I purchase a Unity license?
Why has my subscription license expired?
Can I put my Subscription on hold?
How can I pay off the rest of my subscription?