Symptoms:
- I need to share an asset with another developer on my team.
- I want to consolidate all of my Asset Store purchases into one Unity account.
- I have purchased assets on a former employee's account and need to move the assets to a central account.
- I have purchased a Multi-Entity or Single-Entity use. How do I give my colleagues access to this asset?
Cause:
There are a few reasons you may need to move assets between accounts, whether for administrative or personal reasons. For security reasons, asset purchases are attached to the purchasing account, so it is not possible to transfer them between Unity ID accounts.
Resolution:
Since Asset Store purchases are bound to the purchasing account, it is not possible to transfer them between Unity ID accounts.
A workaround would be to invite the user who requires access to the purchased asset to the organization that the asset is associated with. Once this person is a member of the same organization under which the asset was purchased, they can access it. See the Knowledge Base article 'How do I assign asset seats?'.
Please note: Any assets purchased before May 12, 2020, will not appear under the Asset Management section of your organization. |
If you have assets purchased before May 12, 2020, that you would like converted to the Asset Management system, please contact Customer Service. We can convert your old asset purchases so you can manage the entitlement yourself. Free assets cannot be managed via the Asset Management system or converted.
If instead, you would rather have this asset associated with a different Unity ID, and you have not downloaded the asset, you can request a refund by following the steps outlined in the article, 'How do I request a refund on an asset?'. Once your refund is approved, you can repurchase the asset using the correct Unity ID.
More Information:
Comments
6 comments
I really appreciate this topic being addressed. I cannot understand why there is no way to transfer licenses for asset store purchases. As a developer, I know this cannot be a difficult task. It's a database update. Change owner from x to y. Done.
Hi,
If I purchased assets on my private email and then I start the company. Are these assets still valid for the company I own?
Hi, I wanna share assets purchased to my developer, how can I do that...!!
This Article is a little bit helpful - at least it clearly states "can't be done" which is better than desparately looking for some answers in a Unity forum, always in doubt about how official or up to date a statement is.
However, it still feels a bit like a little punch in the gut.
The usecases are clearly there (and stated above in the article) and the work to implement and maintain this feature should not be that big - I'm with Brian Davis: This should be a feature - it should be a goal to support this. In case there are other reasons that we do not comprehend, conflict of interest, the article should clearly explain them.
I accidentally purchased assets for one organization, but meant to buy them for my personal organization.
The suggested workaround is:
"to invite the relevant person who requires access to the purchased asset to the Organization that the asset is tied to. Once this person is on the same Organization that the asset was purchased under, they will then have access to it."
But I can't invite my personal account to this other organization since they have the same email address.
Back in February, I accidentally purchased some assets without realizing I had the wrong organization selected in the store.
All my assets were purchased with the same email address and same asset store login. Now that my small team is finally moving forward with development, I noticed assets were missing and was hoping it was going to be easy to merge them all under the same org. Sadly, that's not the case.
Any chance Unity is looking into allowing asset ownership/assignment between orgs?
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