Symptoms:
- When I open the Hub, I see a pop-up that asks if I’m still online.
- I can’t open my projects because my offline grace period has expired.
- I want to connect to the internet to confirm my license.
- When I try to use the Unity Editor, I get a pop up with the error message: "You seem to be offline while using a Unity Personal license. Your offline grace period has ended and any open projects will now close unless you connect to the internet to confirm your license."
Cause:
Unity Personal users must ensure they are connected to the internet to use the Editor. There is a 30-day grace period before users are blocked from working offline and must reconnect to the internet. If a Unity Personal user has not been online for 30 days or more, they see a notification in the Hub to connect to the internet to confirm their license.
Resolution:
To connect to the Unity servers, follow the below steps:
- Launch the Unity Hub.
- Select Connect
- After successfully connecting to the internet, you can use the Unity Hub and open projects.
If you see an error message while connecting, something on your network may be blocking the connection to the Unity servers. See the article, ‘I see the error, 'Something went wrong. Please sign in again.', when attempting to sign in to the Unity Hub.‘ for support.
More information:
Error message: 'There was an issue contacting the Unity Servers. Please try again'.
A "License has been revoked" message appears in Unity Hub