Symptoms:
- I just purchased a subscription, but it's not showing on my Unity ID.
- Where's my new subscription?
- I just got a free Unity Pro trial. Where is it?
Cause:
In an effort to consolidate Unity services, subscriptions, and account management, Newly purchased Unity Pro/Industry subscriptions for below condition are now managed via the Unity Cloud Dashboard at cloud.unity.com.
- Unity Pro subscription purchased on or after April 22, 2024
- Unity Industry subscription purchased on or after February 28th, 2025
For any previous Unity Pro/Industry subscriptions purchased before the date above, they will still be shown at the Unity ID Portal (id.unity.com) even after they are renewed.
Resolution:
Provided your purchase was successful, if you can't see your new Unity Pro subscription under id.unity.com, it will be managed at cloud.unity.com instead.
Use the links below to help you manage your new subscription in the Unity Cloud Dashboard:
- How do I find my license serial number?
- How do I assign a Unity subscription license seat to a user?
- How can I revoke a seat on my subscription?
- How do I renew my Unity subscription?
- How do I download my invoice?
- How do I reduce the number of seats on my subscription?
- How do I cancel my subscription?
- How do I return the activations on my Unity Pro license?