Symptoms:
- My last invoice is marked as overdue and I can't trigger a new payment.
- I have some outstanding invoices for Unity DevOps / Unity Gaming Services, but the Payment Method set is not being charged.
Cause:
If a user wants to use the same payment method that was registered before, our payment system automatically merges the new payment method with the existing one. This means that it is not registered as a new payment instrument, and will result in this charge not being triggered.
Resolution:
Taking the following actions should resolve the issue:
- Please navigate via cloud.unity.com > Administration > Payment methods
- Click on Add Payment method
- If you have an alternative card that can be used for the subscription, please add it and set it as the default payment method.
- If you prefer to use the currently set payment card (for example - ending in **1234), you will need to follow these steps:
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- Add a different card or PayPal account (Without funds to avoid unexpected charges) to your account and set it as the default payment method temporarily.
- Delete the existing card ending in **1234.
- Re-add the card ending in **1234 and set it as the default payment method.
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These steps should trigger a new payment attempt within the next 48 hours, allowing the system to process your default payment method in the future.
If the issue is not resolved after 48 hours of making these changes, please contact our Customer Experience team.
More information: