Symptoms:
- I am unable to refresh my Personal license.
- Why do I see an error when trying to refresh my Personal license?
- I want to refresh my Personal license.
- Why can I not refresh my Personal license?
Cause:
If something on your network is blocking the connection to the Unity servers - for example, a slow or intermittent internet connection, antivirus software, a firewall, or a proxy - your Personal license will fail to refresh.
The error message 'Unable to refresh license. Please try again,' can also appear if there is an issue with the Unity Servers. Please visit status.unity.com for more information.
Note: Unity Personal users must ensure they are connected to the internet to use the Editor. There is a 30-day grace period for offline use before you are blocked from working and need to reconnect to the internet. |
Resolution:
To refresh your Unity Personal license, please follow the steps below:
- Launch the Unity Hub.
- Select 'Manage licenses'.
3. Click 'Refresh'.
4. Review the Editor Software Terms, and select 'Agree'.
Alternatively, you can sign out and back into your Unity ID to refresh your license:
1. Launch the Unity Hub.
2. Select the dropdown menu by your initials.
3 Select 'Sign out'.
4. Click the 'Sign in' button.
Troubleshooting:
Alternatively, some users have reported that deleting the “Unity” file from C:/ProgramData/ helped resolve this issue.
If you are unable to refresh your license after completing the above steps, please contact the Customer Experience team with your Hub log files so we can take a closer look at your issue.
More information:
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