Symptoms:
- I see the error message, 'This serial number does not belong to your account'.
- I have my license key and I want to activate it through the Unity Hub, but I'm encountering errors.
- I want to access the Unity Editor, but I am receiving errors in the Hub.
Cause:
In most cases, this happens because the Unity Hub is accessed with a different email than the one associated with the license. This prevents activation.
Resolution:
Please log out from the Unity Hub, then log back in with the account associated with your license key.
However, sometimes, this error occurs because an old license file is blocking the creation of a new one. To resolve this issue, please follow these steps:
- Close the Hub completely using the task manager or similar.
- Using your file explorer, navigate to;
- Windows:
C:ProgramData/Unity
- Mac:
Library/Application Support/Unity
and delete the .ulf file housed there.
- Windows:
- Launch the Hub with administrative permissions. You can do this by right-clicking the Hub and selecting 'Run as admin' or the equivalent option.
- Reactivate your license following the steps outlined in the article, 'How do I activate my license?
If your license is still not activating after troubleshooting, get in touch with Customer Experience, including your Hub log file in your ticket, so we can look closer at your issue.
More information:
- I see the error 'Activation failed: serial number has reached maximum license activations’ when attempting to activate through the Unity Hub. What does this mean?
- I have been asked to provide a log file, where do I find this?
- How do I activate my license?
- Manual activation guide
- How do I return the activations on my Pro/ Plus/ Enterprise license?