Symptoms:
- I have a Unity Industry license but Unity Pro is displayed in the Unity Hub.
- Both Unity Pro and Unity Industry are displayed in the Unity Hub.
- Why does the Unity Hub show both a Pro and Enterprise license?
Cause:
While Unity Industry and Enterprise licenses do not require a serial key for activation, serial keys do still exist.
Since you have an Enterprise or Industry license, this uses Named User Licensing (NUL), which automatically activates your license when you sign in.
If a license is activated using a license key (where you manually input the key), it generates a .ULF (Unity License File). These are typically used for Unity Pro licenses but can be used by Enterprise and Industry customers if they're using a version of the Unity Editor released before 2019 LTS. Versions older than 2019 LTS do not support NUL, so activating using a license key would be appropriate for this use case.
The NUL license file is stored as .XML, whereas the older manually activated license appears as .ULF. When both are present, Unity Hub displays two different license types.
This display may cause confusion, but it does not affect compliance or licensing terms as long as you have the correct license. It does not impact the license's functionality or usage, so you can continue using it without concern.
Resolution:
If you have no need for the .ULF activation to remain on your machine–for example, you're not using any Editor versions below 2019 LTS–you can delete the .ULF following the below steps:
- Close the Hub and all Unity processes from the task manager, or similar.
- Navigate to
C:\ProgramData\Unity
and delete the .ULF housed there. - Relaunch the Hub and sign in.
More information:
- I see the error 'Activation failed: serial number has reached maximum license activations’ when attempting to activate through the Unity Hub. What does this mean?
- How do I activate my license?
- How do I return the activations on my Pro/ Plus/ Enterprise license?
- Which Unity Editor license should I use/purchase?