Symptoms
- I want to reactivate my license but I get the error message "SSl peer certificate or SSH remote key was not OK"
- I cannot reactivate my Unity license due to the below error:
Cause
This error is most frequently caused by a connectivity issue between your machine and our Unity license servers. It can be resolved either by adjusting some of your settings, or by performing a Manual Activation.
Resolution
The reason you are not getting the right SSL certificate or SSH remote key is due to one of the following issues:
- You have a firewall or proxy in place which is interrupting your connection to the license server. Please try allowing these ports in your settings: 80 and 443.
- You have an anti-viral software that is blocking the connection. Please try disabling this and seeing if the Editor will work.
- You have a weak or intermittent Internet connection; please ensure that you have a strong network connection and/or use a different connection method as needed.
- Unity 4.x no longer supports Online Activation as of September 2018. Performing a manual activation is the best workaround for this if you wish to continue using Unity 4.x
If this does not solve the problem you may need to perform a Manual Activation. To activate your license manually, please follow the guidance on our support article 'How do I manually activate my Unity license?'.
If you continue to experience this error after taking the advised steps above, please raise a new support request with Unity.
More Information
How do I return the activations on my Pro/ Plus/ Enterprise license?