Symptoms:
- How do I activate my educational license?
- Is there a mass activation solution?
- I have multiple machines that I need to activate my educational license on.
Cause:
Often, our educational license holders need to activate an entire lab of machines at one time. Although this is not yet possible, we now support batch file activation, making things much easier.
Resolution:
Here is some background on how educational licenses are activated, as Educational Grant License serials are not activated in the standard way.
At this time, we have no official way of activating licenses on multiple machines simultaneously. However, there is a workaround using the command line.
Activating via Command Line:
Windows: C:\Program Files\Unity\Editor\Unity.exe" -batchmode -username name@example.edu.uk -password XXXXXXXXXXXXX -serial E3-XXXX-XXXX-XXXX-XXXX-XXXX –quit
Mac: Applications/Unity/Unity.app/Contents/MacOS/Unity- quit -batchmode -serial
E3-XXXX-XXXX-XXXX-XXXX-XXXX -username name@example.edu.uk -password
XXXXXXXXXXXXX
We cannot give you the exact commands, as every institute's system is set up differently. However, we can give you some typical commands, and you can make changes where you see fit.
See the Unity Manual page for the complete list of command line arguments.
If activating via the command line doesn't work, it may be due to your particular firewalls. Educational firewalls can be tricky to get around with our licenses.
Try allowing these ports in your settings: 80 and 443
As for any firewall which may be running, add the following hostnames:
(IP's may vary):
id.unity.com
api.unity.com
license.unity3d.com
activation.unity3d.com
core.cloud.unity3d.com
sl-http.unity3d.com
developer.cloud.unity3d.com
accounts.unity3d.com
Other than those, there have been reports that the following IPs are contacted (by Google):
74.125.226.222
173.194.43.30
Check your Proxy settings:
HTTPS_proxy=https://proxyusername:proxypassword@proxyaddress.com:8080
UNITY_PROXYSERVER=https://proxyusername:proxypassword@proxyaddress.com:8080
We also recommend checking:
1) Network Issue: Some educational users may be on a restricted internal network with limited or no internet access. To verify connectivity, try pinging the following URL from the command line: https://core.cloud.unity3d.com/api/login.
2) To verify if it is a CACerts.pem issue, can you follow this code:
CACerts.pem is included in the repository.
3) If you can activate from a non-admin account, the activation should work for all non-admin accounts on that machine.
4) If activating on a non-admin account isn't possible, locate the license file after activating it on the admin machine, and save it in a shared area for that machine. This way, if a different user signs in to the device, the license file is shared.
License files (.ULF) are found in the following places:
- Windows: C:\ProgramData\Unity
(If the files are hidden, you must click View and tick the Hidden Items check box.)
- Mac: Library/Application Support/Unity
If the activations still won't go through after toggling your network settings, the workaround is to manually activate the license instead. Guidance for offline (manual) activation is found in the Unity Manual.
Note: Unity can only give you suggestions on the activation process within an educational environment, as each campus's firewalls, IPs, etc., can differ dramatically.
Make sure to move the .ULF file into a shared network area for the students to access. If the file stays in the admin area, student logins won't work.
We always recommend creating a generic admin email address and password login for running the Unity install. Once you have done this, the students will be able to log in when needed.