Symptoms:
- I have been billed for Unity DevOps even though I have cancelled my subscription
- Unity DevOps has charged me despite me reducing my seats and storage usage to be within the 'free tier' threshold
- Why am I being charged for Unity DevOps?
Cause:
Unity DevOps has a free usage tier of up to 3 seats assigned and a maximum of 5GB of cloud storage used.
If either of these are exceeded, they will incur either of the below fees accordingly:
- If over 5GB of storage is used, then a charge will occur at a rate of $0.14/GB/month.
- Every seat used after the initial 3 free seats will be billed at a rate of $7 per seat per month.
Resolution:
Unity DevOps is a pay-as-you-go service which means you are billed for your usage after the billing cycle has concluded.
For example: if you exceed either 3 seats assigned or 5GB total storage used in January and then opt to cancel your DevOps subscription at the end of the same month, you will receive an invoice and a charge in early February to reflect January's usage.
In this example, you would not receive a bill in March to reflect February's usage as the subscription was cancelled at the end of January.
To manage your seats and storage usage for Unity DevOps, please see the below articles respectively:
- 'How to check storage usage for each of my projects in Unity DevOps?'
- 'How can I assign and unassign DevOps seats?'
More information:
Unity Manual - 'Pricing for Unity DevOps'
Unity Cloud Plans pricing page
'How do I cancel my Unity DevOps subscription?'