Symptoms:
- I have already canceled my Plastic SCM or DevOps subscription, but I received a new invoice for it.
- Even though I have canceled my Plastic SCM or DevOps subscription, I am still being charged for this service.
- I thought I canceled my cloud storage subscription, but I was charged again.
Cause:
After canceling a DevOps or Plastic SCM subscription, you might still receive a new invoice and have your money deducted for the service.
Resolution:
Please keep the following information in mind:
DevOps and Plastic SCM operate on a pay-as-you-go subscription model, meaning that you will be charged based on your usage.
As a result, you will receive a final invoice for the billing period up until the cancellation process for the previous month.
Note: You can find the billing period of a service on the invoice, under the Description section. |
Once you settle this last charge, you will no longer receive new invoices for the service.
In case you are unsure whether your current subscription has been canceled, please refer to these articles, respectively:
How do I cancel my Unity DevOps subscription?
Manage Plastic SCM account and subscription
More information:
I deleted my Unity organization but I am still getting charged for Unity DevOps.