Symptoms:
- I am making purchases in the Asset Store, but I am a member of more than one Unity Organization.
- I would like to be able to switch my Organization before making an Asset Store purchase.
- I would like to purchase an asset using my company Organization instead of my personal.
- I would like to be able to assign asset seats to my team, who are not members of my default Organization.
Cause:
All Unity users have a default Unity Organization that is personal to them. Many Unity users may also have company or team Organizations associated with their Unity ID accounts that they have created separately or have been added to.
You may need to purchase through a company account to give colleagues access to the assets you buy.
Resolution:
To switch your Organization before making an asset purchase, follow the steps below:
- Login to your Unity account on the Asset Store.
- Click on the dropdown arrow next to your account information in the top right hand corner of the screen.
- Click on the dropdown arrow shown next to Switch Organization to reveal a dropdown list of available Organizations you can switch to.
You can also double-check you are purchasing under the correct Organization during checkout, as your chosen Organization will be listed under the Organization header as shown below:

Please note: The Organization Switch feature does not currently support the use of Asset Store vouchers. All assets purchased using an Asset Store voucher code, be that provided by Unity, or a third party site such as 'Humble Bundle', will be associated with your default Organization.
More Information:
Comments
2 comments
The note at the bottom might be old and not relevant to the current state of redeeming assets from Humble Bundle, because I just bought a Humble Bundle package, and was able to select a new organization (different from the default one) when associating the assets to my account.
Hello Nicholas,
Thank you so much for your comment and for bringing this to our attention.
The process to redeem Humble Bundle assets and choose an Organization has indeed changed a little since this article was originally published. I will flag this internally so that we can update the information, to help our users, without causing confusion.
Thank you again.
If there is anything else you need in the future, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
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