Symptoms:
- I have purchased an Asset on my account and I need other members of my Organization to access this.
- How do I share an Asset I have purchased with the rest of my team?
- I cannot see my Asset under the 'My Assets' section in the Asset Store.
Cause:
On May 12th 2020, Unity introduced a feature which allows Organization Owners to assign Asset purchases to specific users within their organization. This is similar in nature to subscription license seats.
Resolution:
Assigning Assets via the Unity ID page is supported for both seat-based purchased Assets (Extension Assets) and service-based purchased Assets (single entity & multi entity).
Seat-based Assets (Extension Assets) have a limited seat number, depending on how many seats you purchase. Site-based Assets (single & multi entity) have unlimited seats upon purchase.
To assign an Asset to a user:
- Sign in to your Unity ID at id.unity.com.
- Click 'Organizations' to the left of the screen.
- Click on the Organization used to purchase. (If not changed using the Org switcher, select your default Organization).
- Click 'Asset Management' to the left of the screen.
- Hover over the Asset you would like to manage.
- Click the 'Manage Seats' button.
- Click the box to the right of the user(s) you want to give access to.
- Click the blue 'Assign Seat(s)' button.
The Asset will now appear under the 'My Assets' section in the Unity Asset Store.
Please note: Free Assets cannot be assigned. Each user, needing access to a free Asset, can acquire these Assets as normal. These are then tied to the user's default Organization automatically.
More Information:
Assigning Asset seats is only available for Assets purchased after May 12th 2020.
Comments
4 comments
I just tried this out today. Re-assigned 3 assets but they're not showing up for the other user. Is there a minimum time to wait before these should appear on the other user's account?
Hi Jedediah Steen,
Thanks you for contacting us.
Sorry to hear that you are having issues assigned assets.
I can see that you sent a ticket to us #843015 on Wednesday.
I will grab it and reply directly in the ticket.
Expect a reply later today.
Have a nice day.
I wanted to buy the dynamicBone for 70% off in the promotion, but I failed and bought it for $22 off the list price!
Can I get a refund or a deduction?
Hello Toru, thanks for your comment!
I am sorry to read that you have had a problem purchasing an Asset. I can help you with this no problem.
What I will do for you is create a ticket so that I can investigate this further. Please be on the lookout for en email from us shortly!
Thanks!
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