Customers who successfully purchase from the Asset Store will receive their invoice via email within 24-48 hours. If the invoice is not received after this period, follow the steps in the support article to download it. For unsuccessful purchases, invoices are not generated. Unity cannot provide invoices for Humble Bundle purchases; contact Humble Bundle directly.
Symptoms:
- I made a purchase on the Asset Store, but I did not receive my PDF invoice.
- I have no invoice for my recent purchase.
- I bought something, and I did not get an invoice.
Cause:
If your purchase has been successful, your invoice will be sent to your email and added to your account within 24-48 hours of your purchase.
| Note: If your purchase has been unsuccessful and you see an error, for example, your card provider has blocked the purchase, the invoice will not be delivered to your e-mail. |
Resolution:
If your purchase is completed successfully, you can immediately start using your assets. However, you will need to wait 24 to 48 hours to receive the invoice.
Once this period has passed, you can download your invoice by following the steps in our support article, 'How can I get an invoice for an Asset Store purchase?'
If you still have not received your invoice after 48 hours, please contact Unity Customer Experience, and we will investigate.
| Note: Unity is unable to generate invoices for Humble Bundle purchases as these orders are not made in our system. If you need a Humble Bundle invoice, contact Humble Bundle directly. |