To keep your account information up to date, you may need to update your organization's country. The organization's primary owner must update the location in their main account settings and update the organization’s primary address. Please note that all updates must be made directly by the user through their Unity account dashboard.
Cause:
This article explains how to update the country associated with your Unity organization to ensure your account information is accurate. Your organization's location can affect access to Unity services and is determined by the profile of your organization's owner and the organization’s primary address.
Resolution:
Your organization's country is determined by the location set on the primary owner's account (typically the person who created the organization) and the organization's primary address. The Primary Owner must update their location directly.
- As the Primary Owner, navigate to your account settings: https://cloud.unity.com/account/account-settings.
- Find the Location field and click the pencil icon next to it.
- Select the correct country from the drop-down menu.
- Click Save to confirm the change.
In addition to updating your account information as mentioned above, you should also update your organization’s primary contact address to prevent mismatched data:
- Navigate to https://cloud.unity.com/account/my-organizations and select the organization you want to update.
- In the Organization Settings page, select the pencil icon to the right of your Organization address.
- Update your details and click Save.
If you've followed these instructions and are still facing issues, or if you have other questions regarding your account settings, please contact Customer Experience for further assistance.