この記事は、以下に該当するお客様向けのご案内です。
- フローティングライセンスを利用している
- 誤って取得してしまった Personal ライセンスを Unity Hub から削除したい
症状:
フローティングライセンスを利用している環境で、誤って Personal ライセンスを取得してしまった。
原因:
フローティングライセンスを利用するためのクライアント設定がなされていないか、もしくは古い Unity Hub( < 3.8.0) のバージョンを使用している。
解決策:
以下の手順に従って操作してください。
- Unity Hub からサインアウトする
- Unity Hub を停止する
- Personal ライセンスをクライアントマシンから削除する。Personal ライセンスは以下のディレクトリに存在します。
| プラットフォーム | サービス設定パス |
|---|---|
| Windows | %LOCALAPPDATA%\Unity\licenses\UnityEntitlementLicense.xml |
| macOS | ~/Library/Unity/licenses/UnityEntitlementLicense.xml |
| Linux | ~/.config/unity3d/Unity/licenses/UnityEntitlementLicense.xml |
Personal ライセンスを削除する際には、念のためライセンスファイルを開き、EntitlementGroup というプロパティの id というキーに Personal が含まれているかご確認ください。
例:
<?xml version="1.0" encoding="UTF-8"?>
<root xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<License Id="Terms" IssueDate="2024-09-27T00:38:26.252Z" Version="1.0">
<EntitlementGroups>
<EntitlementGroup Id="15669021305739-UnityPersonal" Namespace="unity_editor" Product="Unity Personal" SubsGroup="Unity Editor" Tag="UnityPersonal" Type="EDITOR">
- Unity Floating Licensing サーバーからサービス設定ファイル (
services-config.json) をクライアントマシンの以下のディレクトリにコピーする。ディレクトリが存在しない場合は作成する。
| プラットフォーム | サービス設定パス |
|---|---|
| Windows | %PROGRAMDATA%\Unity\config\ |
| macOS | /Library/Application Support/Unity/config/ |
| Linux | /usr/share/unity3d/config/ |
- 設定を反映させるためにクライアントマシンを再起動する
- Unity Hub を開き、再度サインインする
参考情報: