この記事は、以下に該当するお客様向けのご案内です。
- フローティングライセンスまたはビルドサーバーライセンスを使用している。
- macOS または Linuxを使用している。
- Unity エディタがクラッシュまたは予期せず終了し、起動できない。
- Licensing client のログに、Error Code: 0x8000000a のエラーが表示される。
原因:
Error Code: 0x8000000a のエラーは、エディタがクラッシュまたは予期せずに終了した後に発生します。エディタが正常に終了できなかった場合、エディタと Licensing client 間の通信に使用される .sock ファイルが保持されてしまいます。これが原因となり、次回以降の起動時にエディタが特定の IPC channel で接続を確立できなくなります。
解決策:
Unity Editor 2020 以前のバージョンをご利用の場合は、以下のバージョンにアップグレードしてください。
- 2020.3.26f1 or higher.
- 2021.2.7f1 or higher.
- 2022.1.0b1 or higher.
プロジェクトが Unity Editor 2019 より前のバージョンで開発されている場合、またはアップグレードができない場合は、手動で .sock ファイルを削除することができます。
- ターミナルで以下のコマンドを実行して、マシン上の .sock ファイルを探します。
Is /tmp/*.sock - マシン上の .sock ファイルの一覧が出力されます。Unity-LicenseClient-[username].sock のような名前のファイルが表示されるはずです。これが削除する必要のあるファイルです。
- ターミナルで以下のコマンドを実行して、ファイルを削除してください。
rm /tmp/Unity-LicenseClient*
参考情報:
Licensing Client と Editor のログファイルは以下のパスに保存されています。
Licensing Client:
- macOS: ~/Library/Logs/Unity/
- Linux:~/.config/unity3d/Unity/
Editor:
- macOS: ~/Library/Logs/Unity/
- Linux: /.config/unity3d/