この記事は、以下に該当するお客様向けのご案内です。
- 以下の内容のメールが届いた。
‘Your license for <server name> will expire. Log in to your Unity ID to regenerate a new license to continue using <subscription name>.’ - 現在のサブスクリプションは年額前払いで、自動更新を有効にしている。
- クライアントはライセンスサーバーに接続できるが、ライセンスを取得することができない。
- Web リクエスト http://<SERVER-IP-ADDRESS>:<PORT>/v1/status が Status: Unhealthy を返す。
原因:
Unity ID Portal で有効期限を更新した後、新しいライセンスが Floating License Server へインポートされていない可能性があります。
解決策:
更新されたライセンスを Floating License Server にインポートする方法:
- Unity ID Portal で Expires フィールドが更新されていることを確認します。 Unity ID portal > Organizations > [Organization name] > License servers をクリックしてください。
- 有効期限が更新されているのを確認後、Download licenses をクリックします。
- サーバー上で、次のコマンドを使用して新しいライセンスをインポートします。
Linux: ./Unity.Licensing.Server import <path-to-downloaded-archive>
Windows: .\Unity.Licensing.Server.exe import <path-to-downloaded-archive> - Unity.Licensing.Server サービスを再起動します。
- 次の API を使用してサーバーをテストします。
http://<SERVER-IP-ADDRESS>:<PORT>/v1/admin/status
インポートが成功した場合の出力は以下のようになります。"serverStatus": "Healthy",
"serverUpTime": "xx days x hours x minutes x seconds",
"serverUpTimeMs": xxxxxx,
"version": "x.x.x"
- クライアント上から、有効なライセンスを取得できるかテストします。まず Unity.licensing.Client のインストールパスに移動します。
Windows: [Unity Editor Dir]\Data\Resources\Licensing\Client\Unity.Licensing.Client.exe
macOS: [Unity Editor Dir]/Contents/Frameworks/Unity.Licensing.Client.app/Contents/ /Unity.Licensing.Client
Linux: [Unity Editor Dir]/Data/Resources/Licensing/Client/Unity.Licensing.Client - --acquire-floating コマンドを実行します。
Windows: .\Unity.Licensing.Client.exe --acquire-floating
macOS: ./Unity.Licensing.Client --acquire-floating
Linux: ./Unity.Licensing.Client --acquire-floating
参考情報:
サーバーのバージョンが 1.10 より前の場合、期限切れの delegation ファイルがコンフリクトを引き起こす可能性があります。以下のディレクトリから古いdelegation ファイルを削除してください。
- Windows: %LOCALAPPDATA%\Unity\licenses\delegations
- Linux: ~/.config/unity3d/Unity/licenses/delegations
Unity ID ページにライセンスサーバーが表示されない場合は、floatinglicense-support@unity3d.com までメールでお問い合わせください。