증상:
- Unity 에셋 스토어에서 에셋을 구매하려고 합니다. 결제가 진행되었지만 내 계정 메뉴에서 구매한 에셋을 확인할 수 없습니다.
- 에셋 스토어에서 구매를 시도하는 동안 다음과 같은 오류 메시지가 표시되어 구매 절차를 완료할 수 없었습니다: https://pay.unity.com/asv2/checkout?orderId=....
- 에셋을 구매하려고 하면 다음과 같은 오류 메시지가 나타납니다: 'Unfortunately, we are unable to process your transaction at this time. Please double-check your billing details, try a new credit card, or contact your bank.'
- 오류 80.0408이 표시되며, 해당 거래가 여전히 보류 중인 상태로 표기됩니다.
원인:
대부분의 에셋은 구매 수 분 후에 계정에 추가됩니다. 이에 따라, 에셋의 구매 및 결제가 정상적으로 진행 된 후 일정 시간 후 구매 항목에 표기될 수 있습니다.
에셋이 내 에셋 항목에 표기되지 않았더라도 주문 항목에서 Unity에서 열기 (Open in Unity) 버튼을 클릭하여 다운로드할 수 있습니다:
해당 버튼을 통하여 Unity에 에셋을 열기 이해서는 에셋을 이용하고자 하는 Unity 프로젝트가 이미 열려 있어야 합니다.
추가로, 결제 진행시 오류 메시지가 표시되면시 해당 결제는 실제로 진행되지는 않았다는 뜻입니다.
해결법:
이 경우 은행이나 카드사를 통해 안내 받으신 결제 건에 대한 메시지나 이메일은 결제 승인 시도를 표기한 건일 뿐이며, 실제로 거래가 진행 된 경우가 아닙니다.
대부분의 은행 및 카드사의 경우, 실패한 결제 승인 건을 조치하는데 최대 2시간이 걸립니다. 해당 주문 결제 건의 실패로 인해 재차 구매를 진행하기 전에 계정에 금액이 다시 입금되었는지 확인하고자 하시는 경우 이용하고 계신 은행 및 카드사에 직접 연락하여 주시기 바랍니다.
또한 다시 한 번 구매를 시도하기 전에 아래와 같은 가이드라인을 확인하여 주시기 바랍니다. 에셋 스토어 구매 시도가 실패하는 이유는 무엇인가요?
참고자료:
신용카드를 결제 수단으로 추가했는데 왜 1달러가 청구되나요?