Symptoms:
- I want to leave an organization and give ownership to another user.
- I want to become the organization owner.
Cause:
Owners can access all settings in their organization's subscriptions across all projects. They are the only users with access to the organization's payment instruments, subscription invoices, and billing information. They can also assign seats, set organization roles, and enable Unity services.
Resolution:
If the current owner still has access to the account:
- Sign into your account.
- Click Organizations to the left of the screen.
- Click the organization you would like to make the change to.
- Click Members & Groups.
- Click the pencil icon to the right of the user you want to edit.
- Click the drop-down menu under Organization Role and select Owner to give them all permissions.
- Click the green Save button.
- The new owner now has full access to remove the previous owner from the organization or downgrade their access.
Please note: If the organization is the current owner's default organization, you cannot change the billable owner, and the current owner cannot leave. |
If you cannot remove the previous owner of the organization, or the owner of the organization has left your company, and it is not their default organization, please submit a support request.
If the person you want to be the owner is not in the organization, please see the article, 'How do I invite a new member to my Organization?'.
More information:
What can Owners, Managers, Users, and Guests do in an organization?
Comments
2 comments
I'm unable to remove the previous 'owner' (actually just the person who set up the account).
Error reads "Member is an admin responsible for subscription payments and therefore cannot be removed from this organization." This is not true (payments are charged to my personal credit card).
The dropdown for changing role is also greyed out and the "Organization Details" only displays one owner (the one I'm trying to remove) though there are three accounts with owner permission.
Hi Bart,
It was good talking to you on Friday via our chat support. Thank you for your feedback.
I would just like to respond here anyway for the benefit of anyone else who runs into the same issue.
Even though you are the user who is being billed for the license. The "accounts billable user" Was set in our system to another user on your organization. That is the reason why you couldn't remove him from your organization.
To have this changed. The account that you would like to be the owner needs to have a valid payment method attached. Once this is done, you can contact us at support@unity3d.com
We will have this changed for you. At which point you can remove the other user.
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