Symptoms:
- I received a voucher/ discount coupon from Unity.
- I follow the link in my email to redeem the voucher, but I see the error, 'The voucher code is not valid. Please try again.'
- My voucher does not work.
Cause:
If the billing information in your Unity Organization is not fully filled out, the voucher cannot be added to your account as our system relies on users having a full address on their default organization.
You may be redeeming your code on the wrong page.
Resolution:
The resolution depends on the type of voucher you want to redeem:
- If you are redeeming a Humble Bundle voucher, follow the instructions in the article, 'How do I redeem my Humble Bundle voucher?'.
- If you are redeeming a discount code, apply it during checkout. For more information, refer to the article 'How do I redeem an Asset Store voucher?'.
Provided that you are on the correct page for your voucher code, ensure your billing information is filled out and up to date and attempt to redeem the voucher again.
You can do this by following the next steps:
- Open your Profile Page on the Asset Store.
- Select Edit Billing Address.
- You will be redirected to your organization page.
- Update your details as necessary.
- Click Save to confirm your changes.
If you continue to have problems redeeming your voucher code, contact the Customer Experience team, including the voucher code you're attempting to redeem, and we will do our best to help.