Symptoms:
- I want to activate my license on a new machine but have run out of activations.
- I have used the available activations on my Pro/ Plus/ Enterprise license.
- I want to return my old activations.
Cause:
Each Unity Plus, Pro, or Enterprise license has a set number of activations. If you want to activate your Unity license key on a new machine and have already used your allowed activations, you can return the activations to free up the license.
Resolution:
Important: The below solution is for online activations only. If you have activated your license manually or purchased your license through a reseller, please contact support with your license key, and we will reset your activations. |
How you purchased your Unity subscription will determine how you return your activations. Use the links below to jump to the solution for your subscription type:
Subscriptions purchased via the online store & sales department.
To return the activations on your license key, follow the below steps:
- Sign in at id.unity.com.
- Click My Seats on the left side of the page.
- Under the Activation window, you can see how many activations you have used and which machines you have activated.
- Click the checkbox next to the machine you want to remove and click Remove selected activations.
Alternatively, if you want to remove all activations associated with your license key, click Remove all my activations.
You can now activate your license on a new machine by following the steps in the article, 'How do I activate my license?'.
Educational Grant, Perpetual, & assigned 'X4' licenses
To return the activations on your license key, follow the below steps:
- Sign in at id.unity.com.
- Click manage your other licenses. on the left side of the page.
- Click the blue Remove all my activations button to release all the online activations currently associated with your license key. Alternatively, click Activations to the right of the screen to view and remove specific activations.
- To remove a specific activation, click the checkbox next to the machine you want to remove and click Remove selected activations.
You can now activate your license on a new machine by following the steps in the article, 'How do I activate my license?' or 'How do I activate my Education Grant License?'.
More Information:
Each standard (Plus, Pro, and Enterprise) Unity license allows a single person to use Unity on two machines they have exclusive use of.
To manage or reassign seats for a subscription, please see the article 'How Can I Revoke A Seat In My Organization?'.
Comments
19 comments
Doesn't work for the new subscriptions. The linked article is also useless...
This is useless and they send you here... You cannot deactivate a licence for your own account online, which is really not helpful. Have to email support.
This article is useless. Also the managing platforms lacks of basic functionality
Hi All. Thanks for your feedback.
The relevance of these solutions depend on the type of license you own!
Unfortunately, you are correct and the activation's on a new subscription cannot currently be returned online via your Unity account.
As stated in the article, if you have access to the machine, activation's can be return via the Unity Editor, by following the below instructions:
If you do not have access to the machine however, or your machine has been updated or crashed, please let our support team know on 'support@unity3d.com' and they will help you to return your activation's!
Is it possible to return my license? I had to reinstall Unity after warranty repair of my machine (so I wasn't able to return license manually), but Unity says that a reached max. limit of activations. It's weird that unity doesn't recognize same hardware when I try to reactivate. Or is there some other problem? I sent a request yesterday, but no response. It will be very nice if I can work instead of looking to my inbox if you decide to repair my subscribe or not :-(...
Thanks for any kind of response.....................
Hi Jindrich,
Looking at your account, I can see that your issue was resolved by our Customer Services team on Monday! The response time for these support requests can sometimes be between 3-5 days :)
Hi Bronte,
yes, since Monady I am working hard every day to catch up our delay in development (which is in fact a couple of years :D). Good side of this delay is that mobile game top charts in 2017 will include a really original and kick ass looking title :-).
Unity is the best software ever exept licensing system :D.
Hi Jindrich,
Good to hear you are up and running again! Good luck with your new kick ass title! :)
I got AGAIN this problem. This time without any changes to the OS or the HW. I opened a ticked 4 days ago and still nothing! This is getting ridiculous!
Please give us the possibility to return licenses from the web account. This is a small feature that will make lots of people happy!
I upgraded a machine to windows 10 and I'm unable to return license from within Unity so I'm trying to follow the following instructions...
When I try and go to the My Seats tab is get a 504 Gateway Time-out error.
Please help. Thanks
Hi Paul,
Sorry to hear you have had some issues returning your activations.
If an update was made to your OS without releasing your activations beforehand, these are essentially 'trapped' on your machine.
Please contact our Unity Customer Service team at support@unity3d.com and they will be able to return your license activations manually!
Thanks
If you're stuck, you can try this direct link:
https://id.unity.com/en/serials
Enter the serial there and you will see the physical machines it's assigned to. You can revoke the license from all machines there.
Hi Julien,
Thanks for the comment,
R3 license (for 5.x Unity version) attached to your account can be added via 'My seat' -> 'Search other license' ->'Enter serial key number'. After then, you will be able to reset the license via online dashboard.
What happens if I want to use my license on more than 2 machines? do I need to buy an additional seat?
Hi Marco.
Thanks for the comment,
In regards to your query, I am sorry to say that each seat allows for a single user to activate on 2 machines that you have exclusive use of as it was mentioned in the article. It means that you need to purchase an additional seat for activating more than 2 machines. However, it's not possible to assign 2 seats to single account. Then, you need to create a secondary account and assign an additional seat to it.
I am a plus subscriber and i couldn´t believe, if someone says to me, how incredibly Big difficulties i am finding for make my license go in my editor:
- I purchased my Plus subscription and after that i add my own seat to my account.
- I put my license key at my unity hub and it detect it perfectly.
- I run the editor (2019.4 and 2019.3 tested) and i cant use my subscription.
- I unninstalled several times, using a registry cleaner, both of Hub and Unity, and reinstalled again. Nothing happens.
- I made another profile in unity web and give the sear to it (using the same pc). Nothing happens.
- I add a seat for a friend of mine, with other computer obviously, and... IT WORKS!
- I deleted his seat and put it again on my profile and... suprise! NOTHING HAPPENS.
PLEASE... HELP!
48h working for solving this... really?
I confess i am a little bit anoying because of this... and a little angry to.
This is certainly not a new issue. At least 4 years and the Unity license system is crap. It crapped on me with my very first license attempt. Now I've had a computer crash - no license at all!
Maybe Microsoft will get the MRTK working with Unreal soon so we can dump Unity.
Hi Larry Aultman
Thanks for contacting us.
I am sorry to hear you have had some problems with your license over the last couple of years. If you want to discuss your situation this further or are experiencing any issues currently, please contact our Customer Service team at support@unity3d.com and they will be be happy to talk about this with you.
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