Symptoms:
- I am being charged in dollars, but I live in Europe.
- I would like to be billed for my subscription in EUR/USD/JPY/BRL/KRW/CNY.
- I do not want to pay for my subscription in USD.
- Why am I being charged dollars for my subscription when I don't live in the USA?
Causes:
Unity bills subscription customers using different currencies. The currency is set as USD by default.
Currencies cannot be changed after a subscription has been purchased.
Resolution:
The current currency options for subscriptions are USD, EUR, JPY, BRL*, CNY, and KRW.
To change the currency shown on subscription options before purchase, scroll to the bottom of the products page and select your preferred currency from the dropdown menu to the bottom right corner of the page.
Please note: BRL is no longer accepted for paid monthly Industry subscriptions or Unity Pro subscriptions. When selected, your Unity Pro subscription will only appear in USD, and Unity Industry subscriptions are only available as prepaid. |
More Information:
We currently only bill in these currencies to simplify the billing process. Understandably, there are many other currencies not included; however, these cover the largest demographic of our users.
How do I purchase a Unity license
Can I switch my subscription payment plan?
Which Services Can I Purchase/ Pay For Using BoaCompra?