Symptoms:
- I am a Plus, Pro, or Enterprise license user and would like to activate Unity.
- I have reached a screen that asks for my serial number/ license key.
- I don’t know what my serial number or license key is.
Cause:
Serial numbers, also known as license keys, let the Unity Editor know what level of access to give each user. This is why it is required as part of the activation process. Personal Edition users do not need a serial number to activate - they have a different option to select during the activation process.
Resolution:
If you are eligible to use the free version of Unity (Unity Personal), you can activate this by selecting Unity Personal during the Unity Hub’s activation procedure.
For Unity Plus, Pro and Enterprise license holders:
If your serial number is not found in your purchasing email, you can locate it through this process:
- After purchasing your Unity Subscription, assign yourself the license seat. If you are not the Owner or Manager of the Organization that owns the seat(s), you can ask the Owner to do this for you.
- After a seat has been assigned to your Unity ID email address, you will receive an email notification. The subject will be “You have been assigned a Unity seat in organization: [Organization name]”
- Your license key will be contained in the body of this email.
- If you do not receive the email with serial number, you can try to remove your seat and assign it again, or contact our Support Team.
You can also find your license key in your ID account, click on My Seats to the left of the screen in your account settings.
Note: If your license was purchased before 28th June 2016, please contact us from your purchasing email address. If you have your invoice number, that will also help us to track down your license.
More Information:
Comments
12 comments
https://store.unity3d.com/account/licenses
Much more accurate way to find your license if you have a 5.x license
Hi Jason,
Thanks for the feedback!
Yes, if you are a perpetual license holder or an old subscription user, then you can find your serial keys, if attached to your Unity account, at 'https://store.unity3d.com/account/licenses'.
If you purchased your license after 28th June 2016, then please follow the above steps!
UNITY PLUS OR PRO
Hey Ahmet,
Are you having issues finding your serial key? If so, I would recommend contacting our Customer Services team on support@unity3d.com. They will be able to track this down for you, if the above instructions are not helping!
Hi! I received my license key but when I’m trying log in to Unity with this key it cause an error «serial expired on Thu Mar 08 16:00:20 GMT 2018...” I bought it just today
Hey!
Sorry to hear you were having some issues activating your license! Looking at your account, I cannot find a specific subscription or serial key.
If you are still having issues, please submit a ticket with our support team who will be able to assist!
The email invitation from Unity currently does not include serial number information. It's useless, please fix.
SoAndSo has assigned you a Unity Teams Basic seat in organization: my-org.
What’s in your plan?
Your plan: Unity Teams Basic subscription gives you exclusive levels of access to Unity Teams Basic features. Click here to get an overview of what’s included.
If you think that this seat should have been assigned to someone else, please let your administrator know.
Please go to support.unity3d.com to get help with any questions about your Unity ID, account, organization(s) and subscription(s).
Sincerely,
The Unity Team
Hi Mark,
Thanks for contacting.
I have just replied to the ticket number #813979. Please, feel free to reach out again if you need further assistance.
The e-mail that gets sent when assigning yourself a set does not contain the serial number. It is also not present on the Unity ID/My Seats page. How am I supposed to find the serial number?
Hi Yuli,
Thanks for reaching out.
This article is fine. However, in our recent version of the Hub, there was a problem that caused you to fail to activate your personal license. I have replied to your ticket#1172153. I hope it can solve your problem.
Please, feel free to reach out again if you need further assistance. Thank you.
Hi, the email still does not include the serial number. I'm trying to add a Pro license, but no luck. Where can I get the licence key?
Hi Maarten,
Thanks for reaching out.
I have answered your question via #1182765. May I ask you to check your mailbox? If you have more questions, please let me know.
Have a nice week!
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