The process to download Unity subscription or Asset Store invoices varies by product and location. Invoices are stored for up to 12 months. Users with manager or user roles cannot access invoices. Subscription invoices may appear in either the old or new dashboard due to migration. Owners can download invoices via the Unity Cloud Dashboard or id.unity.com by navigating to billing or transaction history sections. Download errors may occur if invoices are older than 12 months.
Cause:
The process for downloading invoices differs depending on the Unity product purchased. You may need extra guidance on finding the appropriate place to download your purchase invoice for accounting purposes, for example.
Unity stores invoices for a maximum of 12 months after they are generated. Attempting to download an invoice generated more than 12 months ago will result in an error message being displayed on the screen.
Please note that, due to the ongoing process of migrating subscriptions from our old to the new dashboard, your subscription invoices may be displayed in either the old or the new dashboard. Please try both of the suggested steps below to try and locate your invoices.
| Note: Users within an organization that are assigned manager or user roles cannot view or download invoices. |
Resolution:
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The resolution differs depending on the product purchased. Use the links below to jump to your specific resolution: Download a Unity Editor subscription invoice (purchased online) |
Download a Unity Editor subscription invoice (purchased online)
| The resolution differs depending on where your Unity subscription is housed. If your subscription is housed under the Unity ID portal (id.unity.com), click here to jump to your resolution. |
If your subscription is housed under the Unity Cloud Dashboard and you are the organization's Owner, follow the steps below:
- Navigate to cloud.unity.com and sign in using your Unity ID credentials.
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Using the left-hand menu, select Administration > Billing.
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Click the download icon to the right of the invoice you want to download.
If your subscription is housed under id.unity.com or your subscription was recently migrated, and you are the organization's Owner, follow the steps below:
- Visit id.unity.com and log in to your Unity ID.
- Select Organizations to the left of the screen.
- Select the organization your subscription is associated with.
- Select Transaction History from the left side menu.
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Select the Purchases tab and click Download to download your PDF invoice. (Please check again after 24 hours if the download (Download) is not confirmed)