The Unity licensing system now uses Named User Licensing, unsupported by Editor versions 2019.4 and older. Only users with a serial key can activate these versions; personal users can activate 2019.4.41f2 and later. To open older projects, users must activate their serial key then add the license in Unity Hub. Personal users do not have a license key and therefore, cannot activate Editor versions older than 2019.4.41f2. If errors occur, returning older activations or contacting support may be necessary.
Cause:
Due to recent updates, the Unity licensing system now uses Named User Licensing (NUL), which is not supported by Editor versions 2019.4 and older. As a result, only users with a serial key (Unity Pro, Enterprise, or Industry license holders) can activate these legacy Editor versions. Personal users can activate Editor 2019.4.41f2 and up. Any version prior to 2019.4.41f2 does not support personal activations.
Resolution:
To open projects created in 2019.4 and older, you need to activate your serial key:
| Note: The resolution differs depending on where your Unity subscription is housed. If your subscription is housed under the Unity ID portal (id.unity.com), click here to jump to your resolution. |
Subscriptions housed at cloud.unity.com
- Navigate to cloud.unity.com and sign in using your Unity ID credentials.
- Using the left-hand menu, select Administration.
- Select Subscriptions.
- If you have a User role within the organization, your license key appears to the right of the organization subscription.
If your current organization role is Owner or Manager:- Select the Unity subscription you want to manage.
- Your license key is displayed under the "Users with seats" section of the screen in the Overview tab. Use the copy icon to the left of your serial number to copy the key to your clipboard.
- Select the Unity subscription you want to manage.
If you cannot find your serial number or subscription, first, ensure that you are viewing the correct organization by using the org switcher in the top right corner of the dashboard. If your serial number still does not appear, ask the Owner or Manager of your Unity organization to assign you a license seat, then follow the above instructions. Alternatively, your subscription may be housed in the ID portal. Click here to jump to your resolution.
- Launch the Unity Hub.
- Select the account icon in the top left of the window and sign in using your Unity ID.
- After you are signed in, select Preferences (cog icon).
- Select Licenses > click the blue Add button (you will see your Industry license already activated here which is expected).
- Select Activate with serial number.
- Enter your serial key into the box provided > select Activate license.
You can now open projects created using Unity 2019.4 and older.
If you receive an error during the activation process or still cannot open an older project, you may need to return your older activations first and try again.
If you continue to receive errors, contact Customer Experience with your log files.
Subscriptions housed at id.unity.com
- Navigate to id.unity.com and sign in.
- Select My Seats from the left-side menu.
- Copy your serial key to your clipboard. If you're unable to see your serial key on this page, it may be housed in the Cloud dashboard. Click here to jump to your resolution.
- Launch the Unity Hub.
- Select the account icon in the top left of the window and sign in using your Unity ID.
- After you are signed in, select Preferences (cog icon).
- Select Licenses > click the blue Add button (you will see your Industry license already activated here which is expected).
- Select Activate with serial number.
- Enter your serial key into the box provided > select Activate license.
You can now open projects created using Unity 2019.4 and older.
If you receive an error during the activation process or still cannot open an older project, you may need to return your older activations first and try again.
If you continue to receive errors, contact Customer Experience with your log files.