Symptoms:
- Why does the Hub say my license key is invalid?
- I see an error when I try to activate my license.
- Why won't my Unity license activate?
Cause:
There are many causes for your Unity license failing to activate. These include:
- An expired serial key.
- Insufficient admin privileges.
- An expired license blocking the creation of a new one.
- Network issues.
Resolution:
Since there are numerous causes for a serial number to appear invalid, there are a few different troubleshooting steps to try.
1. Verify serial key
First, ensure that your serial number is correct and valid. See the article, 'How do I find my license serial number?', for more information.
2. Verify machine access privileges
Provided your serial number is correct and current, your issue may be caused by the lack of permission to make changes to your machine's hard drive. To resolve the issue, follow the steps below:
- Close all Hub processes using your task manager or similar.
- Right-click the Hub icon > Run as Administrator. (See, https://support.apple.com/en-us/HT204012
to enable root permissions on Mac.) - Try activating your license again following the steps outlined in the article, 'How do I activate my license?'.
3. Delete an expired .ULF
Sometimes, a previous license file isn't removed correctly during the reactivation of a license. This old license file can block a new one from being created. To resolve this, follow the steps below:
- Close all Hub processes using your task manager or similar.
- Using your file browser, navigate to the following locations:
- Windows:C:ProgramData/Unity
- Mac:Library/Application Support/Unity
- Delete the .ULF housed there.
- Try activating your license again following the steps outlined in the article, 'How do I activate my license?'.
4. Network issues
If something on your network is blocking the connection to the Unity servers, for example, antivirus software, a firewall, or a proxy, your license will fail to activate.
First, try deactivating your firewall/ VPN to see if this is the cause of your error. If you're able to activate your license, the simplest solution is to add entire domains for the following resources in your exception list before enabling your firewall or proxy again:
- unity.com
- unity3d.com
- plasticscm.com
- google.com
- googleapis.com
- microsoft.com
- aka.ms
If you want to selectively control the subdomains, add items from the table in the proxy exception manual page.
See also: Using Unity through web proxies
If you continue to see errors when trying to activate your license after trying each troubleshooting step above, contact the Customer Experience team with the log files found in the below file locations for further assistance:
(Select View and tick the Hidden items checkbox if the files are hidden.)
The Hub log file (info-log.json):
- Windows:
C:\users\<yourusername>\AppData\Roaming\UnityHub\logs
-
Mac:
~/Library/Application Support/UnityHub/logs
-
Linux:
~/.config/UnityHub/logs
-
Window:
C:\users\<yourusername>\AppData\Local\Unity\Unity.Licensing.Client.log
-
Mac:
~/Library/Logs/Unity/Unity.Licensing.Client.log
-
Linux:
~/.config/unity3d/Unity/Unity.Licensing.Client.log
More information: