Symptoms:
- I am unable to activate my license.
- I want to connect to the internet to confirm my license.
- Why do I see an error when I try to activate my license?
- Why is my free license not activating?
Cause:
If something on your network is blocking the connection to the Unity servers, for example, a slow or intermittent internet connection, antivirus software, a firewall, or a proxy, your license will fail to activate.
The error, 'It took too long to activate your license,' can also show if there is an issue with the Unity Servers. See status.unity.com for more information.
Unity Personal users must ensure they are connected to the internet to use the Editor. There is a 30-day grace period for offline use before you are blocked from working and need to reconnect to the internet.
Resolution:
After confirming a slow internet connection is not the cause of your issue and that the Unity Status page does not list any incidents, try deactivating your firewall/ VPN to see if this is the cause of your error.
If you're able to activate your license after clicking the Try again button, the simplest solution is to add entire domains for the following resources in your exception list before enabling your firewall or proxy again:
- unity.com
- unity3d.com
- plasticscm.com
- google.com
- googleapis.com
- microsoft.com
- aka.ms
If you want to control the subdomains selectively, add items from the table in the proxy exception manual page.
See also: Using Unity through web proxies
If you continue to see errors after troubleshooting the above, contact the Customer Experience team with the log files found in the below file locations for further assistance:
(Select View and tick the Hidden items checkbox if the files are hidden.)
The Hub log file (info-log.json):
- Windows: C:\users\<yourusername>\AppData\Roaming\UnityHub\logs
- Mac: ~/Library/Application Support/UnityHub/logs
- Linux: ~/.config/UnityHub/logs
Unity.Licensing.Client:
- Window:C:\users\<yourusername>\AppData\Local\Unity\Unity.Licensing.Client.log
- Mac: ~/Library/Logs/Unity/Unity.Licensing.Client.log
- Linux: ~/.config/unity3d/Unity/Unity.Licensing.Client.log
More information:
I have been asked to provide a log file, where do I find this?