Symptoms:
- I purchased a new Unity subscription, but the dates in the Hub are wrong.
- Why is my license activation date in the Hub different from my account?
- Why is my license expiration date in the Hub different from my subscription expiry?
Cause:
The expiration and activation dates in the Unity Hub are intended to be slightly extended beyond the date of your subscription to allow for a small grace period in case of renewal issues or the subscription being updated during the renewal window.
Resolution:
Slight expiration and activation date discrepancies within the Unity Hub are intended.
More information:
Why is my subscription payment failing?