Symptoms:
- I want to change the currency from USD to another currency for my Organization's subscription payment.
- I do not want to pay for my subscription in USD.
Cause:
Unity bills subscription customers in EUR / USD / JPY / BRL / KRW / CNY. Some customers later realize that there are other currency options available for purchasing a Unity subscription.
Resolution:
While Unity subscriptions can be billed in different currencies, the currency cannot be changed after the subscription has been purchased.
If you purchased the subscription with the wrong currency by mistake, you need to contact the Customer Experience team as soon as possible after the purchase for further assistance.
More information: