Symptoms:
- I want to change the currency from USD to another currency for my Organization's subscription payment.
- I do not want to pay for my subscription in USD.
Cause:
Unity subscriptions can be paid in various currencies, including EUR, USD, JPY, BRL, KRW, and CNY, which can be selected using the options below.
However, once the subscription is purchased and the invoice is issued, the invoice details, such as the currency, cannot be modified.
Resolution:
While Unity subscriptions can be billed in different currencies, the currency cannot be changed after the subscription has been purchased.
If you purchased the subscription with the wrong currency by mistake, you need to contact the Customer Experience team as soon as possible after the purchase for further assistance.
More information: